Jump to content

Calling on @ziemann ... attention Ziemann!! LOL


Recommended Posts

3 minutes ago, Sled_Hed said:

This is probably compounded by waiting on parts and rushing to get the machines assembled and out quickly.

No excuse, but totally agree.

Link to post
Share on other sites
  • Replies 185
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

HAPPY ENDING! Ahhhhhh...... Alrighty- I called Duluth Lawn & Sport at 0900. I dropped it off at 1100. They called me at 1500. And I loaded it back on my trailer at 1630. You can't beat that k

I am shocked that this sled pushes in the corners because supertrax says its the best front end in the galaxy!!!!

Well, it's been six hours so he's either still riding it or has been eaten by wolves. Please post link to site for condolences and memorial donations when confirmed.

Posted Images

45 minutes ago, Bontz said:

No excuse, but totally agree.

Absolutely.  I've worked in mfg long enough to know it does happen when it shouldn't. 

Link to post
Share on other sites
11 hours ago, Ziemann said:

Meh. I'm being a whiney little bitch this morning, aren't I? LOL

Can't blame you I wouldn't be happy either.

Link to post
Share on other sites

HAPPY ENDING! Ahhhhhh......

Alrighty- I called Duluth Lawn & Sport at 0900. I dropped it off at 1100. They called me at 1500. And I loaded it back on my trailer at 1630. You can't beat that kind of service. I love this dealer and they have bent over backwards to take care of me. 

Problem: Lower coolant hose was making contact with the starter mounting bracket and wore a hole through the hose. They replaced the hose, and properly restrained it so that it doesn't reoccur. They looked for other wire/hose wear issues while they had it tore down. 

So, as expected, it was a simple problem with a simple fix. 5 of us are riding tomorrow and I'll spend the day doing some additional fine tuning. 

I installed a Powermadd 4" riser tonight and that should help improve my riding position.

I'm still on the fence about ordering a Grandpa windshield, and a set of Sly Dog skis...... 

  • Like 6
Link to post
Share on other sites
7 hours ago, Ziemann said:

HAPPY ENDING! Ahhhhhh......

Alrighty- I called Duluth Lawn & Sport at 0900. I dropped it off at 1100. They called me at 1500. And I loaded it back on my trailer at 1630. You can't beat that kind of service. I love this dealer and they have bent over backwards to take care of me. 

Problem: Lower coolant hose was making contact with the starter mounting bracket and wore a hole through the hose. They replaced the hose, and properly restrained it so that it doesn't reoccur. They looked for other wire/hose wear issues while they had it tore down. 

So, as expected, it was a simple problem with a simple fix. 5 of us are riding tomorrow and I'll spend the day doing some additional fine tuning. 

I installed a Powermadd 4" riser tonight and that should help improve my riding position.

I'm still on the fence about ordering a Grandpa windshield, and a set of Sly Dog skis...... 

Ooof.  Sounds like it may be a model problem.  We’ll see when more get completed and delivered.

Pete is good people.  :bc:

 

Link to post
Share on other sites
7 hours ago, Ziemann said:

HAPPY ENDING! Ahhhhhh......

 I love this dealer and they have bent over backwards to take care of me. 

 

You don’t hear enough if this these days! 
 

  • Thanks 1
Link to post
Share on other sites

Glad to hear they got you up and going again with a quick turnaround, @Ziemann.  I guess I'll have to make sure I ask the guy setting up my sled to take a peek at that (I know him well & he will treat this sled like it's his).  Hopefully nothing more than a Friday build with a lack of QC vs. something awry with the assembly process.

Link to post
Share on other sites
On 1/12/2022 at 8:56 AM, Ziemann said:

Oh....and the back story?

To protect the engine, it shuts down when it over heats. Even if your in the process of crossing a slush hole on Lake St. Croix.

So yeah, my picker factor was high as it was sitting in slush. Fortunately, it started right back up and I was able to ride it up on to an ice road to let it cool.

Lucky there was ice under that slush hole, that fucker could've drown you...

  • Like 2
Link to post
Share on other sites
10 hours ago, Ziemann said:

HAPPY ENDING! Ahhhhhh......

Alrighty- I called Duluth Lawn & Sport at 0900. I dropped it off at 1100. They called me at 1500. And I loaded it back on my trailer at 1630. You can't beat that kind of service. I love this dealer and they have bent over backwards to take care of me. 

Problem: Lower coolant hose was making contact with the starter mounting bracket and wore a hole through the hose. They replaced the hose, and properly restrained it so that it doesn't reoccur. They looked for other wire/hose wear issues while they had it tore down. 

So, as expected, it was a simple problem with a simple fix. 5 of us are riding tomorrow and I'll spend the day doing some additional fine tuning. 

I installed a Powermadd 4" riser tonight and that should help improve my riding position.

I'm still on the fence about ordering a Grandpa windshield, and a set of Sly Dog skis...... 

 

2 hours ago, Zambroski said:

Ooof.  Sounds like it may be a model problem.  We’ll see when more get completed and delivered.

Pete is good people.  :bc:

 

Must be pretty common if they have that hose in stock

  • Like 1
Link to post
Share on other sites
2 hours ago, krom said:

 

Must be pretty common if they have that hose in stock

Well, only so many places that hose can run if it’s right by the starter mounts.  My guess: many more of these are coming.  Eeesh.

Link to post
Share on other sites
1 minute ago, Zambroski said:

Well, only so many places that hose can run if it’s right by the starter mounts.  My guess: many more of these are coming.  Eeesh.

I don't know what's gonna happen on this ... either it's legit and will end up being a TSB to get sleds in and fixed, or Bryan's sled was a Friday (or Monday hangover) build with something getting missed.  I have a shout out to a buddy of mine who works at the dealership I'm going through, to see if he can tell - or has seen this - on the stuff he's been working on.  I know he will for sure be looking closely at mine ... when it shows up :news:

Link to post
Share on other sites
12 minutes ago, Bontz said:

I don't know what's gonna happen on this ... either it's legit and will end up being a TSB to get sleds in and fixed, or Bryan's sled was a Friday (or Monday hangover) build with something getting missed.  I have a shout out to a buddy of mine who works at the dealership I'm going through, to see if he can tell - or has seen this - on the stuff he's been working on.  I know he will for sure be looking closely at mine ... when it shows up :news:

I’m guessing some type of hose guard was left off?

Link to post
Share on other sites

id say hose not twisted on water pump correctly.it comes off pump then across engine next to starter motor bracket.

usually they have mark on hose for correct orientation.

must be rubbing hard to go that fast!!!

Edited by X2700
Link to post
Share on other sites

Lol, I was wondering how long it would be before mnstang piped in with his electrophobia talk. 

Edited by MnDean
  • Like 1
Link to post
Share on other sites
On 1/13/2022 at 3:01 PM, mnstang said:

Sounds like a problem you may not have had if you didn't have electric start.

 

Just saying.

Hahahahaha, good one!

Link to post
Share on other sites

I've read a couple more reports of the same issue with wear on that coolant hose on HCS. It'll be interesting to see if a TSB is issued for the 650's......

My date of manufacture was 8/26.

Edited by Ziemann
Link to post
Share on other sites
7 hours ago, Ziemann said:

I've read a couple more reports of the same issue with wear on that coolant hose on HCS. It'll be interesting to see if a TSB is issued for the 650's......

My date of manufacture was 8/26.

Maybe the coolant leak is intentional, to stop them from catching fire.  

:dunno:

  • Haha 1
Link to post
Share on other sites
29 minutes ago, Crnr2Crnr said:

Maybe the coolant leak is intentional, to stop them from catching fire.  

:dunno:

In the same way that Cat is selling the "updated" 2012 ProCross to encourage no one to buy one.

Link to post
Share on other sites
40 minutes ago, Deephaven said:

In the same way that Cat is selling the "updated" 2012 ProCross to encourage no one to buy one.

Just like original recipe KFC

Why change?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Trying to pay the bills, lol




×
×
  • Create New...