Jump to content

Recommended Posts

Hey,

I have a 2010 Polaris rush 600. motor is blown and I have traced the fuel injector wires on the PTO side upper injector.  The 2 wires have been rejoined with a wire connector. It looks like the belt blew up and ripped the wires, the previous owner reattached the wires but I guess he didn't do a good job because the pto side over heated, my guess is the injector did not get the proper amount of current from the patched wires. I don't want to rebuild the top end only to have it blow up on me.  Can you swap out the harness and injectors with the motor in the sled? 

does any one have any ideas on what to do, ? you can't just buy 1 injector harness, need to buy all 4  ideas? comments?

my injectors are good, just have patched wires

Link to post
Share on other sites
On 12/5/2018 at 9:34 PM, Taillight said:

Hey,

I have a 2010 Polaris rush 600. motor is blown and I have traced the fuel injector wires on the PTO side upper injector.  The 2 wires have been rejoined with a wire connector. It looks like the belt blew up and ripped the wires, the previous owner reattached the wires but I guess he didn't do a good job because the pto side over heated, my guess is the injector did not get the proper amount of current from the patched wires. I don't want to rebuild the top end only to have it blow up on me.  Can you swap out the harness and injectors with the motor in the sled? 

does any one have any ideas on what to do, ? you can't just buy 1 injector harness, need to buy all 4  ideas? comments?

my injectors are good, just have patched wires

Any thought from the Alaskan Gnome? @AKIQPilot

  • Haha 1
Link to post
Share on other sites
3 hours ago, Frostynuts said:

He,s probably to busy reading up on all the Poolaris 850 sleds that are blowing up, or won,t even fukking start. LOL

I'll try paging him again :lol:   @AKIQPilot

  • Haha 1
Link to post
Share on other sites

I've changed harness on cfi-2 with the engine in the sled.I removed the seat and tank to access. Not sure on what's needed for harnesses but if you get your old one off just solder/ heat shrink the wires back together

  • Thanks 1
Link to post
Share on other sites
On 12/7/2018 at 8:30 PM, HSR said:

I've changed harness on cfi-2 with the engine in the sled.I removed the seat and tank to access. Not sure on what's needed for harnesses but if you get your old one off just solder/ heat shrink the wires back together

Thanks for replying Steve :bc:   I guess our resident Polaris gnome doesn't answer his pager :lol:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...