Jump to content

ECU cal question


Recommended Posts

i have a customers sled in with a bad ecu and have a question on calibrations.
2008 IQ600 with the CFI 600, 4 injector. In looking for a used ecu, do i need to match the exact ecu part number on the top, or am i ok just matching the side part number along with the injector color?

Link to post
Share on other sites

Not sure what happened to your ecu, but I had an 09 600 and the voltage regulator failed and fried the ecu. Polaris did have a service bulletin on them back in the day. Not sure if it pertained to the 08, but something to consider. 
 
 

Link to post
Share on other sites
48 minutes ago, XCR INDY said:

Not sure what happened to your ecu, but I had an 09 600 and the voltage regulator failed and fried the ecu. Polaris did have a service bulletin on them back in the day. Not sure if it pertained to the 08, but something to consider. 
 
 

It's a bad injector driver, mag side full load injector, non repairable. Just needs an ecu, but new is both expensive and currently unavailable. 

Used is my only good option, but im just not clear if i need this specific calibration, or if any "yellow" injector ecu will work

Link to post
Share on other sites
2 hours ago, Tommcat said:

It's a bad injector driver, mag side full load injector, non repairable. Just needs an ecu, but new is both expensive and currently unavailable. 

Used is my only good option, but im just not clear if i need this specific calibration, or if any "yellow" injector ecu will work

Injectors are going to have to match but I also think you will need engine size specific. Can’t imagine a 600 having the same mapping as a 800. I do know when you order a new ecu it needs to be programmed at the dealer.  

Link to post
Share on other sites
21 hours ago, Tommcat said:

It's a bad injector driver, mag side full load injector, non repairable. Just needs an ecu, but new is both expensive and currently unavailable. 

Used is my only good option, but im just not clear if i need this specific calibration, or if any "yellow" injector ecu will work

Just sent this out to a few Polaris faithful that will try to answer your question.  Basically, you need the 600 ECU with the same color as your injectors.  Or buy an ECU and have reprogrammed at a dealer.

  • Thanks 1
Link to post
Share on other sites

I wrestled with this silly cfi-4 for some weeks on end trying to map out a 660. I brought a used 800 ecu to a dealer and for $35, they reprogrammed it to fit a 600, then I had to fiddle fuck around with a power commander to try and dial it in. Nobody had the right calibrations for a 660. I'd say, if it's stock, just run it as is, with a 600 calibration.  It is a LOT of screwing around with the power commander for the end results. I used an AF gauge, dozens of different maps, brought my laptop with me to the long starightaways to change settings, and talked with several dyno guys about these.  Never got it to run longer than ten seconds at WFO before it started running lean, and I tried adding lots of fuel there. Top to bottom brand new engine. Tried different injectors, harnesses, pumps, filters, sensors, two different power commanders... horrible design. Dozens of quarter mile runs trying to get it working. I ran it for almost a year, but last time it seized, I yanked out the engine, and it's sitting under my bench for over five years untouched. Best is to match the injector colours to the ecu, like has been said.

Link to post
Share on other sites

Just got home from riding.  I know back in 2009 we have a 08 700 with a bad ECU and took the ECU off a wrecked 07 600 and refreshed it with the Polaris digital wrench for a 700.  If I remember correctly there's a series of basic questions such as motor and injector colors you had to answer before you could reflash it.  I'll dig around to see if I have some notes yet tomorrow.

  • Thanks 1
Link to post
Share on other sites

Tommy dug up some notes but not sure if this is going to answer your question as I used the Polaris digital wrench which would actually pull the reflash from the Polaris dealer portal.  If its a new ECU you need to initialize it which copies the model ID from the original ECU before it can be flashed.  When we took the used one from the crashed sled there is a section where you can "Change vehicle type".  With in this section you then select the model which will then bring up a list of the injector colors and the latest reflash for each with an associated P/n for the correct flash.  You then select that continue on with authorization code from the dealer portal to continue on.

It's been a while so I can't remember looking at the p/n's your reference on the top and side. The 600, 700, 800 motors did use the same ECU with difference flashes.  If you can find the same model 600 with the same injector color it should work.  I think 2009 or 2010 was the last year they used the 4 injector setup.  

Link to post
Share on other sites
10 hours ago, Tommcat said:

Is digital wrench available to non dealers?

What color injectors does it have?

Link to post
Share on other sites
1 hour ago, Tommcat said:

yellow

I would dig around and find a used CDI box for any 2007 and newer IQ chassis 600 with yellow injectors.  They're either going to be yellow, blue or red.  I know the local guy by us that salvages sleds, water craft and ATV's is real organized and when he pulls sleds apart he labels organizes all parts well.  He may have one.  

  • Like 1
Link to post
Share on other sites
17 hours ago, Doug said:

I would dig around and find a used CDI box for any 2007 and newer IQ chassis 600 with yellow injectors.  They're either going to be yellow, blue or red.  I know the local guy by us that salvages sleds, water craft and ATV's is real organized and when he pulls sleds apart he labels organizes all parts well.  He may have one.  

Does it need to have the same ecu part number from the side? Or just has to be a yellow ecu?

Link to post
Share on other sites
1 hour ago, Tommcat said:

Does it need to have the same ecu part number from the side? Or just has to be a yellow ecu?

Can't remember the side number and its significant.  The 600, 700, 800 use the same ECU with different tunes. Needs to be from a 2007 and newer IQ chassis 600 with yellow injectors.  If you get one from a 700 or 800 it will have a different tune in it and won't work right.

A 600 in a Pro chassis 2010 and new is a 2 injector motor and different ECU.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Trying to pay the bills, lol

×
×
  • Create New...