Jump to content

Recommended Posts

just looking for some advice, this is the newest thing I have touched other than trucks. 
 

kid next door wanted me to look at his 2020 KX250 four stroke.  It shunt down on him and will not start. no smoke before hand. 
I do not know a single thing about this bike other than its newer style engine because there has a second  injector in the intake that came out in 2020. 
I can not find any identifiers any where on the frame for specifics on model. Its got electric start so I am assuming its the cross country model. Of course the kid has no specifics.

No hour meter and I know he is not easy on it, not a track bike tho. 

Either way what I have checked and found so far... New born in the house so I haven't had a lot of time after work. 

Changed spark plug, old one was a little old, figured I would get that out of the way. (it is making good spark) 

Fuel pump is running and pushing fuel, haven checked pressure yet. 

I have the intake box on and tried squirting some starting fluid to see if I could get a puff but nothing... granted its a weird angle and I was nervous to give it to much because this thing is new. Might get some one to help me with this after I check other things.  

Pulled the valve cover to check timing marks and they seem good, I couldn't find anything with the exact bike 2018 was the newest. 
gear dots line up and there is the right amount of pins between (28). Crank mark was looked to be in the right position.

My next step is to check the lash, just need to find the spec. 

My compression tester doesn't go small enough for the spark plug, if valve lash checks out ill have to do that next. 

Head light is something he had put on so Ill have to check what the heck its wired too. 

 

Dealer is  a dick and making him worry about billing, so I am giving this a shot before sending it there. 
also if I fix it I can test drive it :ylsuper:   Any help is greatly appreciated.

 

KX250.thumb.jpg.eac66304fca11dfcf8ce98c2976f731b.jpg

 








 

Edited by Cwhite138
fixed title...
Link to post
Share on other sites
  • Cwhite138 changed the title to KX250 advice

Sorry my bad, just noticed you had already stated it had spark. Next I would check would be fuel pressure. Does it crank over like it has compression or does spin over fast like it's weak?

Link to post
Share on other sites
28 minutes ago, Gocky said:

Sorry my bad, just noticed you had already stated it had spark. Next I would check would be fuel pressure. Does it crank over like it has compression or does spin over fast like it's weak?

Not knowing what it was like new, I do feel like it spins like it has compression. I even put a new battery on it as the kid killed his. 

I was going to make an adapter at work for a leak down & compression test but I do not have the 10mm x 1.0 die needed for the tread pitch... 

Link to post
Share on other sites

I can't help you out here but my god that thing looks fucking rough for a 2020.  Looks like he does a lot of burnouts with it as well.  I'm guessing it has sat on the limiter for most of its life

Link to post
Share on other sites
25 minutes ago, 04nightfire said:

I can't help you out here but my god that thing looks fucking rough for a 2020.  Looks like he does a lot of burnouts with it as well.  I'm guessing it has sat on the limiter for most of its life

that's the second tire! 
I think he drives it on the road more than the dirt honestly. 

I feel bad for his grandmother that bought it for him just to wreck.. jealous too.

Link to post
Share on other sites

I just checked the valves 

One intake was .002mm over other was .102mm. Exhaust were both .203mm. Here is the spec i was using. Pulled off the inter web.
79FE35EC-EE72-469C-8D70-C5C1F1DB23FD.thumb.jpeg.ab99d9f99caf0926f4b3edad65dadf95.jpeg

i guess i need to do a leak down test next?

Tested fuel pressure, because i didn’t know what to expect i used my small gauge which went right up to 50 psi which is its max. dont think thats the problem. 
 

lastly chucked some fuel in the cyl just to see what would happen... got a pop out of the exhaust and thats it.

didn’t have alot of time thats all i checked tonight.

Link to post
Share on other sites

I would want to check compression pressure.  I would suspect it's low.  A bike that looks like that has been neglected and if he ever did change the air filter he probably didn't get it back on right.  I also wouldn't waste any time on it at all.  He clearly doesn't care about it so not sure why you do.  Track bikes owned by squids are the worst combo you can have, 250 moto bikes need proper care to last at all.

  • Like 1
  • Thanks 1
Link to post
Share on other sites
9 hours ago, mnstang said:

I would want to check compression pressure.  I would suspect it's low.  A bike that looks like that has been neglected and if he ever did change the air filter he probably didn't get it back on right.  I also wouldn't waste any time on it at all.  He clearly doesn't care about it so not sure why you do.  Track bikes owned by squids are the worst combo you can have, 250 moto bikes need proper care to last at all.

honestly feel bad for the grandmother lol 

Your right tho, I'm gonna get the adapter for my compression tester tonight,  now that I know I am missing one I want it lol. throw it on see what it says. 
Either way the plastics are going back on tonight and bike up the road to its owner. 

I sent a message and I guess the valves were lashed recently that's why they are in spec. So knowing people, bike wasnt working right, valve lash was long over due got that done. Now the real issue is showing. 

I also read one post last night that there are cases where these bikes are messing up valve seats. Apparently with the addition of the second injector they really raised HP levels higher in the RPM range. This one was probably using ever bit of that extra RPM lol 

Link to post
Share on other sites
3 hours ago, Cwhite138 said:

honestly feel bad for the grandmother lol 

Your right tho, I'm gonna get the adapter for my compression tester tonight,  now that I know I am missing one I want it lol. throw it on see what it says. 
Either way the plastics are going back on tonight and bike up the road to its owner. 

I sent a message and I guess the valves were lashed recently that's why they are in spec. So knowing people, bike wasnt working right, valve lash was long over due got that done. Now the real issue is showing. 

I also read one post last night that there are cases where these bikes are messing up valve seats. Apparently with the addition of the second injector they really raised HP levels higher in the RPM range. This one was probably using ever bit of that extra RPM lol 

The top ends are only good for about 40 hours on those things. Less when abused. They say around every 15 hours the valves should be adjusted. Does he actually ride it enough to put hours on it, or just beat the shot out of it once a week?

Link to post
Share on other sites
2 hours ago, Not greg b said:

The top ends are only good for about 40 hours on those things. Less when abused. They say around every 15 hours the valves should be adjusted. Does he actually ride it enough to put hours on it, or just beat the shot out of it once a week?

I feel like he is on it constantly but who knows. I hear so many bikes but never see who it is from my yard. 
 

Link to post
Share on other sites

 Welp didn’t have anything small enough at the store fit the plug hole.  So i threw the plastics back on. 
 

For shits and giggles i tried bump starting it 3 times in 2nd 3 times in 3rd. Squat. I dont even know if you can bump these new bikes. 
 

i did find if i try to normally start after bumping it i could make it back fire out of the exhaust... 

anyway I ave up. Have my own engines to fix. Picked up a little mower that smokes more than snoop dog on 420 and needs 900cca to start lol
72DB6A81-50DA-483E-958C-AD61D4CE6C45.thumb.jpeg.e63ccce9aea02e2f0b2f958fd4a70e75.jpeg

  • Like 1
Link to post
Share on other sites
19 minutes ago, Cwhite138 said:

 Welp didn’t have anything small enough at the store fit the plug hole.  So i threw the plastics back on. 
 

For shits and giggles i tried bump starting it 3 times in 2nd 3 times in 3rd. Squat. I dont even know if you can bump these new bikes. 
 

i did find if i try to normally start after bumping it i could make it back fire out of the exhaust... 

anyway I ave up. Have my own engines to fix. Picked up a little mower that smokes more than snoop dog on 420 and needs 900cca to start lol
72DB6A81-50DA-483E-958C-AD61D4CE6C45.thumb.jpeg.e63ccce9aea02e2f0b2f958fd4a70e75.jpeg

What year is that?

Edited by 800renegaderider
Link to post
Share on other sites
9 minutes ago, 800renegaderider said:

Nice older than I thought should be fun project 

It was my grandfather’s also im excited to get it in working order.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Trying to pay the bills, lol

×
×
  • Create New...