Jump to content


Photo

ZR 600 Clutch Problems


  • Please log in to reply
3 replies to this topic

#1 Gasman58

Gasman58

    Member

  • Members
  • PipPip
  • 315 posts

Posted 25 February 2012 - 10:15 AM

It sounds like you know about Arctic Cat Clutching after you tuned jammin's sled. I was riding in Boulder Junction about 3 weeks ago & cracked the spider in my clutch. Went to JR Motorsports and got a rebuilt clutch, it looked like new. I had the dealer in boulder put it on & adjust the secondary. Later I was riding across the lake and slowly eased into the throttle. When it got to about 60mph I put it to the bar & the motor felt like it would not go any faster. It has 50 weights in the clutch. Another guy told me to put 54 or 56 weights in it. Do you have any recommendations. I am going up north the 29th and could probably get some weights and change them out & try some different things.
Any help would be appreciated.
Thanks, Ron
I think I drank a beer at your place 2 years ago at the drags in Wonder Lake.

#2 FreezerBurnt

FreezerBurnt

    \>>>SUMMER SUX<<</

  • Members
  • PipPip
  • 19,943 posts

Posted 26 February 2012 - 05:38 PM

What yr 600?

If it's a 2001 and up ZR 600 with APVs I would say go 56g Poo weights :beer_cheers:


Yellow/white primary
10-56 Poo weights(heel grinded a touch)
57/50 Cat helix
EPI Green Secondary spring

My 01 ZR 600 VEV rocked with that set up for trail riding and off trail

If its a 2000 or older NON APV 600 that set up won't work

#3 Gasman58

Gasman58

    Member

  • Members
  • PipPip
  • 315 posts

Posted 26 February 2012 - 08:44 PM

Thanks for the info. I am heading up to Boulder Junction Wednesday Morning, so I won't have time to put all that stuff together.
What I did do is go to Mikes on hwy 59 and get the stock spring & 54G weights.
The rebuilt said 500 or 600cc clutch. Pretty sure it was setup for a 500 with the 50G weights.

If you had great results with that setup I will probably try and hunt that stuff down off season and give it a go for next year.

Thanks again.

Ron

#4 Gasman58

Gasman58

    Member

  • Members
  • PipPip
  • 315 posts

Posted 09 March 2012 - 10:11 PM

Fixed the clutch problem once & for all.

Attached Thumbnails

  • 0303121552a.jpg





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users